Автор Тема: Проблема с атрибутами и кириллицей  (Прочитано 74 раз)

09 Февраль 2018, 18:34:13
  • Новичок
  • *
  • Сообщений: 4
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Добрый день!

Помогите, пожалуйста, разобраться с проблемой.

Если в админке магазина отключить "Специальные символы в URL", то невозможно сохранить товар, выдает ошибку Неправильное поле link_rewrite (English (English)).
Если не отключать - то при выборе цвета товара, в ссылке получаются русские буквы, что плохо.

В каком месте исправить?

В прошлой теме при добавлении значения атрибута можно было сразу и желаемое ЧПУ дописать, а в этой нет такого поля  :'(

Помогите кто чем может)

1.6.1.10
09 Февраль 2018, 20:08:26
Ответ #1
  • Партнер
  • Ветеран
  • ****
  • Сообщений: 22556
  • Репутация: +17130/-1
  • Разработка веб-сайтов и веб-программирование
    • Просмотр профиля
1. ЧПУ можно менять в ручную. Отключайте "Специальные символы в URL" и в карточке товара заполняйте поле ЧПУ латиницей.
2. Для значений группы атрибутов можно задавать URL (ЧПУ) во всех версиях prestashop ветки 1.6.
Интернет-магазин под ключ.
Какой выбрать движок для интернет магазина ?
Какой движок лучше ?
Magento или Prestashop ?
Решение всех Ваших вопросов в создании Интернет-магазина.
09 Февраль 2018, 23:45:13
Ответ #2
  • Новичок
  • *
  • Сообщений: 4
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
1. ЧПУ можно менять в ручную. Отключайте "Специальные символы в URL" и в карточке товара заполняйте поле ЧПУ латиницей.
2. Для значений группы атрибутов можно задавать URL (ЧПУ) во всех версиях prestashop ветки 1.6.

У меня сайт на престашоп (разных версиях) с 2011 года, я всегда ЧПУ товара пишу вручную.
Для значений группы атрибутов - есть возможность, а вот для каждого атрибута - например, для цвета - нет. Теперь, когда покупатель выбирает цвет в товаре, в ссылке появляются русские буквы :(
В дефолтной теме было поле для каждого атрибута, а в купленной куда-то исчезло. См. скриншот в первом сообщении.
И вот, спустя год после покупки, наконец дошли руки до сайта. Но даже, казалось бы, такое простое исправить не найду где  :-\
10 Февраль 2018, 14:01:41
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 15039
  • Репутация: +14588/-5
  • Сообщество PrestaShop
    • Просмотр профиля
Тема влияет на внешний вид. На показ атрибутов в админки никакого влияния нет. Дело скорее всего в модулях. Какой-то из модулей переоределил базовый класс prestashop атрибутов. Нужно проверять модули.
Сначало отключите кеширование и включите перекомпиляцию шаблонов. Потом начните проверку.