Автор Тема: [решено]Ошибка "Страница не найдена" когда пытаюсь открыть Back Office  (Прочитано 13 раз)

14 Ноябрь 2017, 17:26:34
  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Все что я сделал - убрал следующий блок:



Но после этого я не имею вообще возможности зайти в back office.

Как это пофиксить?

И почему "Welcome" вообще поламал back office? (на сколько я понял это просто фишка которая показывает куда кликать что бы показать функциональность для новых пользователей песташопа)
14 Ноябрь 2017, 17:32:54
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 33082
  • Репутация: +26762/-0
    • Просмотр профиля
Открепление модуля из хука не дожно так влиять. Кеш почистите, зайдите в другом браузере. Показ ошибок включите. Модуль, если не нужен, удалять нужно.
14 Ноябрь 2017, 17:50:25
Ответ #2
  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Я понимаю что это не должно влиять)
Но при этом я уверен что это случилось именно после этого. Почему? Потому, что я перед этим откреплял другие ненужные мне блоки и нажимал кнопку сейв. И смотрел все ли ок на фейсе сайта.
Но при откреплении именно даного блока после нажатия на кнопку сейв оно вместо обновления страницы меня перенесло на пустую страницу и.... все. После этого меня разлогинило с админки и зайти на страницу админки я не могу.

________________________________
Все оказалось тривиальнее, но проблема осталась.
я не тот адрес указывал (я писал просто "http://localhost/admin", а нужно было "http://localhost/admin215y2nszz").

Так вот.... Сейчас актуальная проблема -- пустая страница вместо админки...

В другом браузере - сначала показало форму логина в админку, а после логина - пустая страница (This page isn’t working. localhost is currently unable to handle this request.)

включил логирование по туториалу: http://www.inmotionhosting.com/support/prestashop-16/enable-error-reporting


админка запустилась, но показан эрор:
Unknown error on line 77 in file C:\\wamp64\\www\\vendor\\prestashop\\smarty\\sysplugins\\smarty_internal_templatebase.php(157) : eval()'d code
[4096] Object of class Link could not be converted to string

на самой странице редактирования блоков выдает ошибку:
Unknown error on line 77 in file C:\\wamp64\\www\\app\\cache\\dev\\smarty\\compile\\9d\\5f\\4c\\9d5f4c31f1c072f3426b58a92dbffa6e0a5a1a2a.file.content.tpl.php
[4096] Object of class Link could not be converted to string

но я ничего не менял в темплейтах. Почему это могло случится?
14 Ноябрь 2017, 18:12:59
Ответ #3
  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Проблему пофиксил.

Оказалось что случилась какая-то ошибка во время анхука и оно не анхукнуло полностью то что должно было.

В дебагМоуд я залогинился, закрыл ошибку и повторно сделал анхук. после чего проблема пропала.


Спасибо большое!