Автор Тема: Не показываются подкатегории в модуле категорий  (Прочитано 1641 раз)

27 Февраль 2013, 21:40:12
  • Новичок
  • *
  • Сообщений: 1
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Общий привет!
Я совсем зеленый, еще начинающий престоман, если что сильно не пинайте!
Скачал бесплатный шаблон  под названием leo_converse_v15x.
Если скачивать магазин с основного сайта разработчика престы, то там по умолчанию установлена тема, в которой есть модуль категорий товаров. Так вот там в настройках есть возможность установить " динамический (анимирированный) режим подуровней ". Если он включен, то на морде магазина отображаются как и родительские, так и дочерние категории, причем с подключенным javascript, который дает возможность открыть или закрыть дочернюю группу.
А на шаблоне leo_converse_v15x тот же модуль категорий, но категорически отказывается показывать дочерние подкатегории. Их даже в html-коде не видать.
Пытался сравнивать файлы blockcategories.tpl  и  blockcategories.php но так толком и не смог разобраться.
Обратился за помощью на ихнем форуме, а там тишина.
Подскажите, пожалуйста, где править код, чтобы заработали подкатегории?
Или может как то удалить этот модуль а потом установить. Как будет правильно?
Спасибо!
27 Февраль 2013, 22:14:40
Ответ #1
  • Администратор
  • Ветеран
  • *****
  • Сообщений: 102480
  • Репутация: +34219/-0
    • Просмотр профиля
Цитировать
Пытался сравнивать файлы blockcategories.tpl  и  blockcategories.php
там должны быть файлы js.
Нужно смотреть как реализованно выпадающее меню в этой теме. Без темы не возможно определить, что не работает.
27 Февраль 2013, 22:47:54
Ответ #2
  • Ветеран
  • *****
  • Сообщений: 33085
  • Репутация: +26762/-0
    • Просмотр профиля
На этом сайте, все бесплатные шаблоны prestashop под версию 1.4.
Там переделанный модуль меню. Если ставить на prestashop 1.5, то лучше отключить этот модуль и включить стандартный.
03 Февраль 2017, 23:05:27
Ответ #3
  • Новичок
  • *
  • Сообщений: 1
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Была похожая проблема - антивирус просто удалил при проходе файлик из темы (может тама и был вирус - но.. все ж) .
{CAV}Txt.Malware.Agent-5746765-0 : "ваш сайт"/themes/new_prestashop_new/js/tools/treeManagement.js => /usr/local/maldetect/quarantine/treeManagement.js.2360229936
Вернул обратно файл treeManagement.js и все заработало.