Автор Тема: Поврежденный файл конфигурации  (Прочитано 207 раз)

06 Май 2017, 14:19:40
  • Новичок
  • *
  • Сообщений: 35
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Здравствуйте! При загрузке шаблона в Настройки -> Шаблоны, показывает ошибку "Поврежденный файл конфигурации".
Шаблон в формате .zip, версия Prestashop v1.6.1.13.
06 Май 2017, 15:03:07
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 14198
  • Репутация: +14571/-2
  • Сообщество PrestaShop
    • Просмотр профиля
В таком случае расспаковывайте архив и устанавливайте тему в ручную.
07 Май 2017, 10:52:32
Ответ #2
  • Новичок
  • *
  • Сообщений: 35
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В таком случае расспаковывайте архив и устанавливайте тему в ручную.
Уже и так пытался, заменял theme и modules, но тема так и осталась стандартной и в разделе бэк-офиса так же не отображается.
07 Май 2017, 11:06:16
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 86543
  • Репутация: +25419/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В папке темы есть файл config.xml?
07 Май 2017, 12:43:35
Ответ #4
  • Новичок
  • *
  • Сообщений: 35
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В папке темы есть файл config.xml?
Да, есть такой файл. В нем нужно что-то откорректировать?
07 Май 2017, 13:10:45
Ответ #5
  • Ветеран
  • *****
  • Сообщений: 14198
  • Репутация: +14571/-2
  • Сообщество PrestaShop
    • Просмотр профиля
В этом файле должны быть описаны настройки темы
<?xml version="1.0" encoding="UTF-8" ?>
<theme>
<version value="...">
<ccc available="..." />
<guest_checkout available="..." />
...
</version>
</theme>
Еще должен быть файл /config/xml/themes/название темы.xml в нем расширенные настройки
<?xml version="1.0" encoding="UTF-8"?>
<!-- Copyright PrestaShop -->
<theme version="..." name="название темы" directory="папка темы">....
08 Май 2017, 12:13:03
Ответ #6
  • Новичок
  • *
  • Сообщений: 35
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В этом файле должны быть описаны настройки темы
<?xml version="1.0" encoding="UTF-8" ?>
<theme>
<version value="...">
<ccc available="..." />
<guest_checkout available="..." />
...
</version>
</theme>
Еще должен быть файл /config/xml/themes/название темы.xml в нем расширенные настройки
<?xml version="1.0" encoding="UTF-8"?>
<!-- Copyright PrestaShop -->
<theme version="..." name="название темы" directory="папка темы">....

Первый файл и код есть, а вот второго файла нету. Там не название темы.xml, а default.xml.
08 Май 2017, 12:34:50
Ответ #7
  • Ветеран
  • *****
  • Сообщений: 14198
  • Репутация: +14571/-2
  • Сообщество PrestaShop
    • Просмотр профиля
Значит тема сделана с ошибками или она не для вашей версии prestashop. Ищите другую тему.
08 Май 2017, 16:58:46
Ответ #8
  • Новичок
  • *
  • Сообщений: 35
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Спасибо, обновился до версии PrestaShop 1.7 и установил тему, всё исправно. Тему можно закрыть.