Автор Тема: ЧПУ проблема с буквой Х в русских УРЛ  (Прочитано 49 раз)

20 Апрель 2017, 12:25:01
  • Новичок
  • *
  • Сообщений: 2
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Здравствуйте, prestashop 1.6.1.5
 
При включенных ЧПУ(Frendly URL) и специальные символы в УРЛ(Accended URL). Урлы в которых есть русская буква Х перестают работать.

Пример УРЛ URL: prestashop16/дом/8-хлеб-хумус-хомяк.html    выдает 404

При выключении только ЧПУ, все урлы работают с любыми русскими буквами.
 
Установлен модуль убирающий id из урл, без этого модуля то же самое. буква х в урл с включенным ЧПУ и спец символами делает страницу 404.

Помогите разобраться. Спасибо.
20 Апрель 2017, 12:51:52
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 2992
  • Репутация: +72/-5
  • Сообщество PrestaShop
    • Просмотр профиля
Удали модуль убирающий id, верни обратно оригинальные файлы, которык модуль заменил.
Оключи чпу, удали htaccess и опять включи чпу. Должно заработать без ошибок.
20 Апрель 2017, 15:17:57
Ответ #2
  • Новичок
  • *
  • Сообщений: 2
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Удали модуль убирающий id, верни обратно оригинальные файлы, которык модуль заменил.
Оключи чпу, удали htaccess и опять включи чпу. Должно заработать без ошибок.

Только что проект скинул на хостинг там все работает, у меня винда 10 может из за нее, на локальном старом денвере работает, на опенсервере эта ошибка появляется еще пробовал ampp там тоже такая же ошибка.
20 Апрель 2017, 15:22:24
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 14006
  • Репутация: +14568/-2
  • Сообщество PrestaShop
    • Просмотр профиля
Точно проблема в конфигурации сервера. Сравнить нужно конф.файлы удаленного сервера и локального.