Автор Тема: Не загружается админка  (Прочитано 192 раз)

14 Июня 2015, 13:18:06
  • Новичок
  • *
  • Сообщений: 19
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Путь прописан правильно, но страница с админкой не загружается. Как получилось:напортачила с версткой, пытаясь добавить колонку. Решила сделать бэкап. Благо хостинг хранит резерв. Прислали. Так как я вообще во всем этом ни чего не шарю, а искать и править нужные файлы для меня страшнее трехдневного геморроя с загрузкой базы, решила обновить вообще все и базу и файлы. Все загрузила, сайт открывается(хотя по верстке все стало еще хуже, чем после того как я туда влезла) но висит ошибка :
Warning: Cannot modify header information - headers already sent by (output started at /home/irisa-shop/irisa-shop.ru/docs/config/config.inc.php:1) in /home/название/сайт/docs/classes/controller/FrontController.php on line 815 + не открывается страница админки. Никакой ошибки не выдает, просто вообще ничего не загружает. Не знаю связано ли это как то с ошибкой на сайте, но все равно прикрепляю функцию, которая находится в файле  по указанному в ошибке пути в линии 815.
public function initHeader()
{
// P3P Policies (http://www.w3.org/TR/2002/REC-P3P-20020416/#compact_policies)
header('P3P: CP="IDC DSP COR CURa ADMa OUR IND PHY ONL COM STA"');

/* Hooks are volontary out the initialize array (need those variables already assigned) */
$this->context->smarty->assign(array(
'time' => time(),
'img_update_time' => Configuration::get('PS_IMG_UPDATE_TIME'),
'static_token' => Tools::getToken(false),
'token' => Tools::getToken(),
'priceDisplayPrecision' => _PS_PRICE_DISPLAY_PRECISION_,
'content_only' => (int)Tools::getValue('content_only'),
));

$this->context->smarty->assign($this->initLogoAndFavicon());
}
Если кто в курсе - буду благодарна за помощь. Ошибку гуглила, в основном ответы на англоязычных источниках, и всегда проблема в разных файлах. Ответы про FrontController.php не нашла.Спасибо.
14 Июня 2015, 15:18:38
Ответ #1
  • Модератор
  • Ветеран
  • *****
  • Сообщений: 86339
  • Репутация: +25417/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Два варианта, ошибка в коде шаблона, нет закрывающего тега "{}" или кавычек, или ошибка в модулях.
Нужно проверить шаблоны темы, отключить все модули (проверять подключая по одному).
Если не знаете php, smarty, html, css, то лучше наймите специалиста.
14 Июня 2015, 16:57:10
Ответ #2
  • Новичок
  • *
  • Сообщений: 19
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Спасибо. проблема решена. Оказалось не до конца загрузилась база.