Автор Тема: Даунгрейд  (Прочитано 98 раз)

22 Марта 2015, 11:31:17
  • Фрилансер
  • *
  • Сообщений: 193
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Куча тем не работает на последних версиях.  Хочу сделать даунгрейд в пределах 1.6 версии.  Например сейчас 1.6.14 , а нужно 1.6.9 .

Если тупо заменить все файлы и не трогать базу. Будет работать ?

Или может какие-то папки отдельно заменить а не всё ? По моему можно не трогать Config, img, cache самому стереть
22 Марта 2015, 11:47:45
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 13627
  • Репутация: +14563/-1
  • Сообщество PrestaShop
    • Просмотр профиля
Если откатывать с версии 1.6.14, то нужно учитывать все изменения в этих версиях, заменить файлы, которые были изменены (в релизе версии есть описание), сравнить таблицы и поля в бд, при разнице изменить. Еще учесть обновение модулей. Некоторые модули с последними обновлениями не будут работать. Нужно также искать версию модуля, которая входит в prestashop 1.6.9.
Самый простой способ, это установить заново 1.6.9 и перенестви в нее товары.