Автор Тема: пропали все ссылки  (Прочитано 604 раз)

01 Августа 2014, 17:57:23
  • Новичок
  • *
  • Сообщений: 13
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
после серии неудачных обновлений и бэкапа пропали все ссылки, работает только главная страница
на все ссылки ошибка 404:
The requested URL /12-odezhda was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

ребята, в чем может быть проблема? очень нужна помощь...
01 Августа 2014, 18:22:23
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 33028
  • Репутация: +26761/-0
    • Просмотр профиля
Отключите ЧПУ и удалите htaccess, потом очистите кеш и пробуйте.
01 Августа 2014, 18:28:07
Ответ #2
  • Новичок
  • *
  • Сообщений: 13
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Отключите ЧПУ и удалите htaccess, потом очистите кеш и пробуйте.

чпу отключил, половина ссылок начали работать: например корзина, категории. а вот, например, /price-drop (страница  скидок) и ей подобные выдают уже на самой престе ошибку.
какой именно htaccess надо удалить?
01 Августа 2014, 18:34:47
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 33028
  • Репутация: +26761/-0
    • Просмотр профиля
Удалить htaccess в корне сайта.
Ссылки такого вида "/price-drop" и не должны работь при отключеном чпу.
01 Августа 2014, 19:53:37
Ответ #4
  • Новичок
  • *
  • Сообщений: 13
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Удалить htaccess в корне сайта.
Ссылки такого вида "/price-drop" и не должны работь при отключеном чпу.

благодарю! помогло :) включил обратно ЧПУ и все нормально.
только одно "но", пропал ползунок цены в фильтре... есть может и на эту проблему решение?
01 Августа 2014, 21:55:34
Ответ #5
  • Ветеран
  • *****
  • Сообщений: 13635
  • Репутация: +14563/-1
  • Сообщество PrestaShop
    • Просмотр профиля
Шаблон модуля многоуровневой навигации нужно проверить. Если у вас был свой шаблон, то при обновлении prestashop меняет шаблоны на стандартные. После обновления нужно востановить шаблоны из сохранненого архива.
04 Августа 2014, 23:41:14
Ответ #6
  • Новичок
  • *
  • Сообщений: 13
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Шаблон модуля многоуровневой навигации нужно проверить. Если у вас был свой шаблон, то при обновлении prestashop меняет шаблоны на стандартные. После обновления нужно востановить шаблоны из сохранненого архива.

он, в принципе, и был такой как надо изначально, просто нет этого ползунка и все... один раз появился, теперь пропал опять. бред...
05 Августа 2014, 10:21:22
Ответ #7
  • Ветеран
  • *****
  • Сообщений: 33028
  • Репутация: +26761/-0
    • Просмотр профиля
Похоже что проблема в кеширование. Отключите кеширование и включите перекомпиляцию.
Конфигурация > Производительность
Smarty
Кэш шаблона
- Принудительная перекомпиляция
Кэш
- Да
Очистите кеш сайта и браузера.