Автор Тема: Не отображаются картинки в EI  (Прочитано 1981 раз)

21 Марта 2012, 12:16:31
  • Новичок
  • *
  • Сообщений: 2
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Добрый день.
Недавно обратил внимание, что в EI не отображаются картинки товара. Причем на главной странице и при выборе товара картинки отображаются, а при выборе "коллекций" или отборе товара по каким-либо критериям картинки нет. Нет ни иконки, ни каких либо еще значков.
В других браузерах этой проблемы нет. Все отображается корректно
Подскажите, где смотреть и как решить эту проблему.
Спасибо
21 Марта 2012, 12:43:45
Ответ #1
  • Фрилансер
  • *
  • Сообщений: 198
  • Репутация: +4/-0
  • Разработка и программирование сайтов
    • Просмотр профиля
    • Разработка и программирование сайтов
Добрый день.
Недавно обратил внимание, что в EI не отображаются картинки товара. Причем на главной странице и при выборе товара картинки отображаются, а при выборе "коллекций" или отборе товара по каким-либо критериям картинки нет. Нет ни иконки, ни каких либо еще значков.
В других браузерах этой проблемы нет. Все отображается корректно
Подскажите, где смотреть и как решить эту проблему.
Спасибо

IE он очень категоричен к путям где располагаются картинки, посмотрите какие пути проставлены в файлах шаблонов которые выводят коллекции и фильтрации по критериям.
21 Марта 2012, 12:58:44
Ответ #2
  • Новичок
  • *
  • Сообщений: 2
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Где в панели администратора это можно увидеть?
21 Марта 2012, 13:27:48
Ответ #3
  • Фрилансер
  • *
  • Сообщений: 198
  • Репутация: +4/-0
  • Разработка и программирование сайтов
    • Просмотр профиля
    • Разработка и программирование сайтов
Где в панели администратора это можно увидеть?
Это нужно смотреть в файлах вашей темы, к примеру для ваших коллекций - как я понял категорий, файл шаблона находится в category.tpl. Вы можете сравнить пути вывода картинок в category.tpl с шаблоном где картинки выводятся нормально - в вашем случае вывод товаров для главной - modules\homefeatured\homefeatured.tpl и найти причину.

Также для начала можете попробывать перегенерировать картинки коллекций -  категорий из админпанели (НАСТРОЙКИ - ИЗОБРАЖЕНИЯ).
23 Марта 2012, 16:20:36
Ответ #4
  • Ветеран
  • *****
  • Сообщений: 980
  • Репутация: +5/-0
  • Иногда заглядываю
    • Просмотр профиля
    • Помощь патентообладателям по продаже патентов.
Очень интересно, у меня та же проблема в версии престы 1.4.2.5,
а в версии 1.4.5.1 этой проблемы нет.
Сравнил оба файла category.tpl одинаковые.
Но когда смотришь код html страницы
то в случае 1.4.2.5 строка вывода выглядит так

<img src="/29-subcategori/m-2000.jpg" alt="" width="" height="" />

а в 1.4.5.1 вот так

<img src="/c/29-subcategori/m-2000.jpg" alt="" width="" height="" />

где то пропадает адрес папки с файлами.

Знает кто ни будь где надо поправить?
Не боги горшки обжигают, не зачем им такой хренью заниматься.
24 Марта 2012, 11:59:46
Ответ #5
  • Администратор
  • Ветеран
  • *****
  • Сообщений: 102473
  • Репутация: +34218/-0
    • Просмотр профиля
Путь к картинке определяется в функции getCatImageLink
public function getCatImageLink($name, $id_category, $type = null)
{
}
24 Марта 2012, 12:25:20
Ответ #6
  • Ветеран
  • *****
  • Сообщений: 20889
  • Репутация: +25279/-0
  • Prestashop - просто и эффективно
    • Просмотр профиля
Цитата: Vasiy
то в случае 1.4.2.5 строка вывода выглядит так
<img src="/29-subcategori/m-2000.jpg" alt="" width="" height="" />
а в 1.4.5.1 вот так
<img src="/c/29-subcategori/m-2000.jpg" alt="" width="" height="" />
где то пропадает адрес папки с файлами.
Знает кто ни будь где надо поправить?
Добавьте "/c" в адрес картинки в function getCatImageLink.
Эксперт Prestashop - решения всех проблем, написание модулей, создание тем для интернет-магазинов под Prestashop.
Эксперт Magento - создам сайт на Magento, программирование кастомных модулей для Magento, кастомизация тем Magento.
Лучшие цены!!!
24 Марта 2012, 21:50:39
Ответ #7
  • Ветеран
  • *****
  • Сообщений: 980
  • Репутация: +5/-0
  • Иногда заглядываю
    • Просмотр профиля
    • Помощь патентообладателям по продаже патентов.
Цитата: Vasiy
то в случае 1.4.2.5 строка вывода выглядит так
<img src="/29-subcategori/m-2000.jpg" alt="" width="" height="" />
а в 1.4.5.1 вот так
<img src="/c/29-subcategori/m-2000.jpg" alt="" width="" height="" />
где то пропадает адрес папки с файлами.
Знает кто ни будь где надо поправить?
Добавьте "/c" в адрес картинки в function getCatImageLink.


Перепробовал все возможные подстановки "/c", IE все равно не выводит картинку, хотя в коде страницы адрес '/c' появляется.
Не боги горшки обжигают, не зачем им такой хренью заниматься.
26 Марта 2012, 10:02:48
Ответ #8
  • Администратор
  • Ветеран
  • *****
  • Сообщений: 102473
  • Репутация: +34218/-0
    • Просмотр профиля
1. Проверьте путь к картинке, откройте картинку в отдельном окне браузера.
2. Побробуйте устанавливать полный адрес для картинки http://site.ru/.....
3. Проверьте размеры для картинок, какие значения указанны в админке.
4. Попробуйте указать эти размеры в шаблоне.