Автор Тема: PHP Fatal error: Declaration of Doctrine Нужна помошь  (Прочитано 88 раз)

13 Январь 2023, 02:57:51
  • Новичок
  • *
  • Сообщений: 8
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
не могу справится сам. что с этим делать

[12-Jan-2023 17:38:23 America/Toronto] PHP Fatal error: Declaration of Doctrine\DBAL\Driver\PDOConnection::query() must be compatible with PDO::query(string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs) in /home/admin/htdocs/www.market.100platform.com/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php on line 70

   2023-01-12 18:39:56   
66.220.198.202 - - [12/Jan/2023:18:39:56 -0500] "GET /ru/module/productcomments/CommentGrade?id_products%5B%5D=1&id_products%5B%5D=2&id_products%5B%5D=3&id_products%5B%5D=4&id_products%5B%5D=5&id_products%5B%5D=6&id_products%5B%5D=7&id_products%5B%5D=8 2.0" 500 0 "https://www.market.100platform.com/ru/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36"
2023-01-12 18:40:09   
66.220.198.202 - - [12/Jan/2023:18:40:09 -0500] "GET /phppsinfo.php 2.0" 200 1368 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36"
13 Январь 2023, 10:57:49
Ответ #1
  • Модератор
  • Ветеран
  • *****
  • Сообщений: 86687
  • Репутация: +25428/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Версию php смените. Prestashop не поддерживает PHP 8.1
13 Январь 2023, 11:04:18
Ответ #2
  • Новичок
  • *
  • Сообщений: 8
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Версию php смените. Prestashop не поддерживает PHP 8.1

Да сто раз менял, туда сюда. ставил все от 5.6 до 8.1 нехрена. я вот припоминаю, что что то было с зонами. что типа нужно ставить типа нулевую зону. я как то с этим уже мучался. но сейчас инфы нет
13 Январь 2023, 12:30:06
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 16599
  • Репутация: +14630/-5
  • Сообщество PrestaShop
    • Просмотр профиля
Показ ошибок в prestashop включите.