Автор Тема: Ошибка при обновлении с 1.7.5.2 до 1.7.6.1  (Прочитано 70 раз)

23 Сентябрь 2019, 14:59:36
  • Фрилансер
  • *
  • Сообщений: 134
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Привет всем!
 При обновлении версии с 1.7.5.2 до 1.7.6.1 модулем  1-click upgrade Все время ошибка [Ajax / Server Error for action unzip] textStatus: "error " errorThrown:" " jqXHR: " "
В чем может быть проблема и как решить?
23 Сентябрь 2019, 16:11:28
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 15669
  • Репутация: +14602/-5
  • Сообщество PrestaShop
    • Просмотр профиля
Причин много. Начните с хостинга, перенестите сайт на локалку и там пробуйте обновить. Обновится, тогда пробдема в хостинге.
23 Сентябрь 2019, 18:43:17
Ответ #2
  • Фрилансер
  • *
  • Сообщений: 134
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Причин много. Начните с хостинга, перенестите сайт на локалку и там пробуйте обновить. Обновится, тогда пробдема в хостинге.

Перенес на локалку. Сайт открывается нормально, в админку зайти не могу белая страница.
24 Сентябрь 2019, 14:55:54
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 33195
  • Репутация: +26762/-0
    • Просмотр профиля
В модулях ошибка. Включите режим отладки.
24 Сентябрь 2019, 17:31:58
Ответ #4
  • Фрилансер
  • *
  • Сообщений: 134
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В модулях ошибка. Включите режим отладки.

Включил режим отладки (через файл) Админка на локалке открылась, обновился до 1.7.6.1 Вроде обрадовался
Решил посмотреть модули, кликаю менеджер модулей и получаю
"Oops! An Error Occurred
The server returned a "500 Internal Server Error".
Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused. "

Возвращаюсь назад, включаю режим отладки и снова иду в менеджер модулей и получаю такое:


FatalThrowableError
HTTP 500 Internal Server Error
Type error: Argument 3 passed to JXBlogRepository::__construct() must be an instance of PrestaShopBundle\Translation\TranslatorComponent, instance of PrestaShopBundle\Translation\DataCollectorTranslator given, called in D:\OSPanel\domains\arinkasoap.com\modules\jxblog\jxblog.php on line 65

    Exception Logs 2 Stack Trace

Level    Channel    Message
DEBUG 16:30:10    doctrine    SELECT name FROM ps_module WHERE active = 1
INFO 16:30:11    request    Matched route "admin_module_manage".
DEBUG 16:30:11    security    Read existing security token from the session.
DEBUG 16:30:11    security    User was reloaded from a user provider.
DEBUG 16:30:11    doctrine    SELECT p0_.id AS id_0, p0_.id_employee AS id_employee_1, p0_.id_module AS id_module_2, p0_.date_add AS date_add_3, p0_.date_upd AS date_upd_4 FROM ps_module_history p0_ WHERE p0_.id_employee = ?
WARNING 16:30:11    translation    Translation not found.
WARNING 16:30:11    translation    Translation not found.
WARNING 16:30:11    translation    Translation not found.
CRITICAL 16:30:11    php    Type error: Argument 3 passed to JXBlogRepository::__construct() must be an instance of PrestaShopBundle\Translation\TranslatorComponent, instance of PrestaShopBundle\Translation\DataCollectorTranslator given, called in D:\OSPanel\domains\arinkasoap.com\modules\jxblog\jxblog.php on line 65
INFO 16:30:11    php    User Deprecated: Implementing "Symfony\Component\HttpKernel\DataCollector\DataCollectorInterface" without the "reset()" method is deprecated since Symfony 3.4 and will be unsupported in 4.0 for class "Csa\Bundle\GuzzleBundle\DataCollector\GuzzleCollector".
CRITICAL 16:30:11    request    Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalThrowableError: "Type error: Argument 3 passed to JXBlogRepository::__construct() must be an instance of PrestaShopBundle\Translation\TranslatorComponent, instance of PrestaShopBundle\Translation\DataCollectorTranslator given, called in D:\OSPanel\domains\arinkasoap.com\modules\jxblog\jxblog.php on line 65" at D:\OSPanel\domains\arinkasoap.com\modules\jxblog\src\JXBlogRepository.php line 33

Что опять не так? Куда теперь копать?
24 Сентябрь 2019, 19:46:28
Ответ #5
  • Ветеран
  • *****
  • Сообщений: 1506
  • Репутация: +41/-1
  • Сообщество PrestaShop
    • Просмотр профиля
Модуль jxblog удалять нужно. Не подходит он под новую версию prestashop.
24 Сентябрь 2019, 19:59:32
Ответ #6
  • Фрилансер
  • *
  • Сообщений: 134
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Модуль jxblog удалять нужно. Не подходит он под новую версию prestashop.
В списке установленных модулей я его не нахожу.
В папке с модулями есть такой.
Как его лучше удалить?
24 Сентябрь 2019, 20:47:46
Ответ #7
  • Фрилансер
  • *
  • Сообщений: 134
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Не знаю правильно сделал или нет:
Удалил из папки модули все,что начинается на jx (я так понял это все относится к этому модулю)
В базе поиском нашел и удалил все что относится к jxblog
Вроде все работает. Еще пару дней потестирую на локалке потом сделаю на хостинге.
Спасибо огромное за подсказки!
25 Сентябрь 2019, 11:48:38
Ответ #8
  • Фрилансер
  • *
  • Сообщений: 134
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Какая то засада.
На хостинге ни в какую не хочет обновляться, все время ошибка  [Ajax / Server Error for action unzip] textStatus: "error " errorThrown:" " jqXHR: " "
Уже и удалил этот модуль и включаю режим отладки ни чего не помогает.
Написал хостеру, отправляет на форумы prestashop
Что за хрень? На локалке то все получилось.