Автор Тема: не войти в admin на localhost  (Прочитано 1579 раз)

12 Февраля 2013, 00:49:13
  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
 Windows 7  denver

Установил на localhost    prestashop_1.4.4.0
в директорию C:\WebServers\home\shop\www

удалил папку install, переименовал admin

по http://www.shop/  магазин открывается, работает.
а в админ не войти: только авторизация и зацикливается

  http://www.shop/admin623/login.php?redirect=index.php

Что делать??? подскажите,плз.
12 Февраля 2013, 08:32:39
Ответ #1
  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Такое впечатление, что надо выставить время ожидания для редиректа на index.html больше???
Так ли?
12 Февраля 2013, 11:34:55
Ответ #2
  • Администратор
  • Ветеран
  • *****
  • Сообщений: 102467
  • Репутация: +34217/-0
    • Просмотр профиля
13 Февраля 2013, 16:00:24
Ответ #3
  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Здравствуйте.
Поставил на Windows 7 denver на localhost     prestashop_1.4.4.0
C:\WebServers\home\shop147\www
PrestaShop работает.  http://www.shop147/
Никак не могу войти в админ.  http://www.shop147/admin123/login.php
http://www.shop147/admin123/login.php?redirect=index.php
проскакивает ожидание index.php  и опять  окно Авторизации.
на неправильный пароль реагирует сообщение invalid password
Поставил в localhost prestashop_1.5.3.1 eng - Авторизация работает, в админку захожу правильно.
Необходимо работать с 1.4 русской.
Я так понимаю:
у меня не создается cookie или время ожидание мало
не получается Redirect to admin panel
/* Creating cookie */
$cookie->id_employee = $employee->id;
$cookie->lastname = $employee->lastname;
$cookie->firstname = $employee->firstname;
$cookie->email = $employee->email;
$cookie->profile = $employee->id_profile;
$cookie->passwd = $employee->passwd;
$cookie->remote_addr = ip2long(Tools::getRemoteAddr());
$cookie->write();
/* Redirect to admin panel */
if (isset($_GET['redirect']))
$url = strval($_GET['redirect'].(isset($_GET['token']) ? ('&token='.$_GET['token']) : ''));
else
$url = 'index.php';
Или настройки сервера неправильны

Скажите что делать?
Крайне необходимо


13 Февраля 2013, 17:10:07
Ответ #4
  • Администратор
  • Ветеран
  • *****
  • Сообщений: 102467
  • Репутация: +34217/-0
    • Просмотр профиля
Включить режим отладки. В файле config/config.inc.php
@ini_set('display_errors', 'on');
define('_PS_DEBUG_SQL_', true);
Проверить сервер на соотвествие требованием.
Расширение php_mbstring на сервере установлено?
Установить кодировку в UTF-8.