Автор Тема: Prestashop 1.7  (Прочитано 2280 раз)

17 Марта 2016, 19:31:38
  • Ветеран
  • *****
  • Сообщений: 1010
  • Репутация: +2/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Кто ставил Prestashop 1.7?
Хочу посмотреть что нового будет в престе, но не охота все зависимости dev ветки устанавливать.
Кто знает где можно поиграться с новой версией?   
01 Апреля 2016, 12:00:13
Ответ #1
  • Ученик
  • Новичок
  • *
  • Сообщений: 1
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Хочу посмотреть что нового будет в престе, но не охота все зависимости dev ветки устанавливать.
Кто знает где можно поиграться с новой версией?
Где можно посмотреть перечень нововведений в новой версии?
01 Апреля 2016, 12:06:47
Ответ #2
  • Партнер
  • Ветеран
  • ****
  • Сообщений: 22094
  • Репутация: +17108/-1
  • Разработка веб-сайтов и веб-программирование
    • Просмотр профиля
Полная информация по Prestashop 1.7 есть на оф. сайте - Prestashop 1.7

На других сайтах можно тоже найти про Prestashop 1.7
Цитировать
Что ждать от Prestashop 1.7 ?

Прежде всего в новой версии Prestashop 1.7 частично обновлена архитектура, используется фреймворк Symfony2 и шаблонизатор Twig. Но движок Prestashop 1.7 не будет полностью переведен на Symfony, так как разработчики стремились сохранить совместимость версий. В prestashop 1.7 Symfony будет использоваться только для back-office, это касается только 2 разделов Товаров и Модулей. Тоже самое относится и к замене Smarty на Twig. Twig это язык шаблонов фреймворка Symfony , в Prestashop 1.7 он будет использоваться для разделов Товары и Модули, которые были переведены на Symfony. Остальные разделы, глобальные переменные, общие хуки по-прежнему будут использовать Smarty. Такой подход дает возможность использовать модули от версии 1.6 в Prestashop версии 1.7.  Только модули из разделов Товары и Модули нуждаются в адаптации. Но это не создаст больших проблем, так как на странице настроек товара, будет переключатель, который позволит выбрать между использованием Smarty+старая архитектура или Twig+Symfony2.
Еще один важный вопрос, будут ли темы от Prestashop 1.6 совместимы с Prestashop версии 1.7 ? Тут не все так оптимистично, как с модулями. Темы от Prestashop 1.6  не будут работать на Prestashop 1.7. В структуре темы произошли коренные изменения, будет использоваться базовая тема, а персональные темы построенны на расширении основной теме, еще один момент, Bootstrap больше не используется.

Скопировано с сайта http://webstudio-uwk.ru/prestashop/prestashop-v17/
Интернет-магазин под ключ.
Какой выбрать движок для интернет магазина ?
Какой движок лучше ?
Magento или Prestashop ?
Решение всех Ваших вопросов в создании Интернет-магазина.
01 Апреля 2016, 12:12:37
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 20838
  • Репутация: +25276/-0
  • Prestashop - просто и эффективно
    • Просмотр профиля
Это перевод релиза с prestashop.com. Немного измененный.
Лучше чем первоисточник нет ресурса.

Скоро обещают на doc.prestashop.com выложить Developer Guide для Prestashop 1.7
Эксперт Prestashop - решения всех проблем, написание модулей, создание тем для интернет-магазинов под Prestashop.
Эксперт Magento - создам сайт на Magento, программирование кастомных модулей для Magento, кастомизация тем Magento.
Лучшие цены!!!
13 Апреля 2016, 10:25:18
Ответ #4
  • Ветеран
  • *****
  • Сообщений: 105576
  • Репутация: +39545/-0
    • Просмотр профиля
    • Webstudio UwK
Кто ставил Prestashop 1.7?
Хочу посмотреть что нового будет в престе, но не охота все зависимости dev ветки устанавливать.
Кто знает где можно поиграться с новой версией?   

Prestashop 1.7
Cоздание интернет сайтов Webstudio UwK
08 Августа 2016, 11:00:38
Ответ #5
  • Новичок
  • *
  • Сообщений: 13
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Подскажите, пожалуйста, устанавливаю сайт на PS первый раз.Сайт сделан на Bootstrap, а в 1.7 он больше не используется. В моём случае может лучше 1.6 использовать?
08 Августа 2016, 11:15:34
Ответ #6
  • Ветеран
  • *****
  • Сообщений: 13147
  • Репутация: +14553/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Сейчас выбора нет. Устанавливать нужно стабильную версию prestashop 1.6.
То что тема сделана на Bootstrap ничего страшного, темы в prestashop менять легко. Потом установите новую тему.
08 Августа 2016, 11:38:01
Ответ #7
  • Новичок
  • *
  • Сообщений: 13
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
спасибо
08 Ноября 2016, 08:06:28
Ответ #8
  • Старожил
  • ****
  • Сообщений: 312
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Добрый день,

Если в делать новый магазин, то лучше уже устанавливать новую версию 1.7 или 1.6.1.7 с не стандартым шаблоном?

Спасибо.
08 Ноября 2016, 10:08:21
Ответ #9
  • Пользователь
  • **
  • Сообщений: 72
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Добрый день,

Если в делать новый магазин, то лучше уже устанавливать новую версию 1.7 или 1.6.1.7 с не стандартым шаблоном?

Спасибо.

Я бы 1.6 ставил, если такие кардинальные изменения и в 1.7 не работают темы 1.6, то лучше 1.6 и купить подходящую тему, ну а если сам можешь написать тему, то почему бы и не 1.7
08 Ноября 2016, 11:29:07
Ответ #10
  • Ветеран
  • *****
  • Сообщений: 2169
  • Репутация: +49/-4
  • Сообщество PrestaShop
    • Просмотр профиля
Лучше prestashop 1.7. Но ты его попробуй сначала просто установить. Потом о теме говорить будем.
08 Ноября 2016, 13:32:36
Ответ #11
  • Старожил
  • ****
  • Сообщений: 312
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Лучше prestashop 1.7. Но ты его попробуй сначала просто установить. Потом о теме говорить будем.

Так и решил сделать, но уже столкнулся с проблемой. В Instalatron нету последней версий, а в ручную установить не получаеться. Пока даже не могут помочь с тех. поддержки сервера.
А о теме потом говорить не поздно будет? :)))
08 Ноября 2016, 13:54:58
Ответ #12
  • Ветеран
  • *****
  • Сообщений: 2169
  • Репутация: +49/-4
  • Сообщество PrestaShop
    • Просмотр профиля
Вот я про то и пишу. Чтобы установить prestashop 1.7, нужно многое знать. Когда сам сможешь установить, то тему адаптировать сможешь без труда.
Ну а если сам не можешь или не хочешь, найми программиста. В этом случае тебы будет все равно какая версия, какие проблемы с темой, пусть у программиста об этом голова болит.
08 Ноября 2016, 15:23:16
Ответ #13
  • Старожил
  • ****
  • Сообщений: 312
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Вот я про то и пишу. Чтобы установить prestashop 1.7, нужно многое знать. Когда сам сможешь установить, то тему адаптировать сможешь без труда.
Ну а если сам не можешь или не хочешь, найми программиста. В этом случае тебы будет все равно какая версия, какие проблемы с темой, пусть у программиста об этом голова болит.

Может Instalatron в помощь будет :)
Так как сейчас лучше делать: ставить версию 1.6.1.17 с не стандартным шаблоном, а когда настанет 2018 или раньше, нанять программиста или сейчас нанять программиста и сразу поставить версию 1.7 со стандартным или не стандартным шаблоном?

И в back office в 1.7 намного труднее работать?
08 Ноября 2016, 16:13:50
Ответ #14
  • Ветеран
  • *****
  • Сообщений: 13147
  • Репутация: +14553/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Рано на Prestashop 1.7 переходить. Только первая стабильная версия вышла. Подождать нужно пару недель, ошибки повыявляют и исправят, тогда и переходить.