Автор Тема: Как исправить отсутствие логотипа с письмах, рассылаемых Prestashop?  (Прочитано 531 раз)

10 Июня 2015, 13:37:52
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Заметил, что ВО ВСЕХ письмах, которые отсылает Prestashop, вместо логотипа в шапке письма отображается крестик.
Причем к самому письму файл с логотипом прикрепляется, а вот в самом теле письма его нет(см. скриншот внизу письма).
Не подскажете, как исправить проблему?
Хочу еще добавить, что в (меню заказы-статусы-править) есть опция просмотр шаблона. Там тоже крестик отображается вместо логотипа.
Кроме того, в (меню-локализация-переводы-шаблоны e-mail) есть режим html-редактора, если в нем прописать ссылку на конкретный файл, то логотип появляется. Но править вручную почти сотню шаблонов как то не хочется. Может есть решение поизящнее?

Файл одного из шаблонов писем(статусного сообщения об успешной обработке платежа), находящегося в папке www\mails\ru\ прикреплен внизу письма:
10 Июня 2015, 15:20:37
Ответ #1
  • Ветеран
  • *****
  • Сообщений: 33009
  • Репутация: +26760/-0
    • Просмотр профиля
В почтовой программе разрешено показывать изображения?
У вас же картинка с лого прикреплена к письму.

Изображение и значения переменных не показывает в просмотре шаблона письма. Эти значения заполняются только в самом письме.
Для лого должна быть строка с переменной shop_logo
<img src="{shop_logo}" alt="{shop_name}" />
10 Июня 2015, 16:17:40
Ответ #2
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Строка в шаблонах присутствует, а изображение логотипа нету в шапке письма, присутствует только файл логотипа в приложении к письму
10 Июня 2015, 16:30:00
Ответ #3
  • Ветеран
  • *****
  • Сообщений: 13446
  • Репутация: +14561/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Настройте свою программу для показа html версии и разрешите подгружать графику.
10 Июня 2015, 17:54:52
Ответ #4
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Дело не в этом.
Я еще обнаружил,что и ссылки тоже кривые в письмах приходят
Вот, к примеру, письмо об обработке заказа(внизу в пристежке)
А в нем такая ерунда в ссылках:

lsp://5/%7Bshop_url%7D - это ссылка "ИМПУЛЬС" вверху и внизу письма
lsp://5/%7Bhistory_url%7D - это ссылка "Истории заказов"
lsp://5/%7Bmy_account_url%7D - это ссылка "Моя учетная запись"
lsp://5/%7Bguest_tracking_url%7D?id_order=%7Border_name%7D - это ссылка "Гостевое отслеживание"

И в части логотипа тоже добавляются такие же символы

<img src="%7Bshop_logo%7D" alt="ИМПУЛЬС" /></a>
Хотя в шаблоне все корректно прописано

<img src="{shop_logo}" alt="{shop_name}" />
10 Июня 2015, 17:59:22
Ответ #5
  • Ветеран
  • *****
  • Сообщений: 20849
  • Репутация: +25278/-0
  • Prestashop - просто и эффективно
    • Просмотр профиля
Это или проблемы хостинга, почтового сервера. Или почтового клиента. Кто-то из них перекодирует спец.символы.
Эксперт Prestashop - решения всех проблем, написание модулей, создание тем для интернет-магазинов под Prestashop.
Эксперт Magento - создам сайт на Magento, программирование кастомных модулей для Magento, кастомизация тем Magento.
Лучшие цены!!!
10 Июня 2015, 19:02:00
Ответ #6
  • Ветеран
  • *****
  • Сообщений: 2521
  • Репутация: +58/-4
  • Сообщество PrestaShop
    • Просмотр профиля
У меня так было когда правил шаблоны через редактор файлов хостинга. Он при сохранении менял все скобки, пробелы на вот такой код.
Скачал все шаблона к себе и в нодпаде отредактировал, залил опять на сервер и все заработало.
10 Июня 2015, 19:21:19
Ответ #7
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Это или проблемы хостинга, почтового сервера. Или почтового клиента. Кто-то из них перекодирует спец.символы.

Вот это интересная мысль.
Сейчас попробую организовать отправку через SMTP-клиента и посмотрю, есть ли изменения
10 Июня 2015, 19:22:22
Ответ #8
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
У меня так было когда правил шаблоны через редактор файлов хостинга. Он при сохранении менял все скобки, пробелы на вот такой код.
Скачал все шаблона к себе и в нодпаде отредактировал, залил опять на сервер и все заработало.

Так в том то и дело, что я проверил все файлы через Notepad, там нету ничего подозрительного.
10 Июня 2015, 20:19:13
Ответ #9
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Это или проблемы хостинга, почтового сервера. Или почтового клиента. Кто-то из них перекодирует спец.символы.

Вот это интересная мысль.
Сейчас попробую организовать отправку через SMTP-клиента и посмотрю, есть ли изменения

Проверил. Через SMTP стороннего сервера приходит точно такое же письмо.
Значит проблема не в хостинге.
10 Июня 2015, 20:58:48
Ответ #10
  • Ветеран
  • *****
  • Сообщений: 13446
  • Репутация: +14561/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В другой программе получать письма пробывали? Адрес сайта какой? Можно проверить шаблоны html в браузере.
10 Июня 2015, 21:46:53
Ответ #11
  • Новичок
  • *
  • Сообщений: 28
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Вот немного вроде сам разобрался с Вашей помощью)
Вообщем, что касается логотипа, то оказалось, что его размер просто не помещался в отведенное ему место в письме.
В шаблоне размер места под логотип вообще не прописан.
После добавления в шаблон по адресу www\themes\default\mails\ru следующей строки при размере логотипа 255х65

<img src="{shop_logo}" alt="{shop_name}" width="255" height="65" />
вместо дефолтной

<img src="{shop_logo}" alt="{shop_name}"
все заработало