Автор Тема: Проблема с модулем водяной знак  (Прочитано 535 раз)

19 Июля 2014, 16:59:10
  • Пользователь
  • **
  • Сообщений: 61
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Установил стандартный модуль водяной знак. Настроил его. Для новых товаров водяной знак появляется, а вот на старых картинках нет. Картинки перегенерировал, ничего не меняется. Правда при перегенерации возникло 8 ошибок типа: "Original image is missing or empty error". Может быть с этим проблема, хотя не думаю что из за 8 ошибок для всех товаров не работает(их более 500). Версия престы 1.5.4.1. Может кто-нибудь сталкивался с такой проблемой? Помогите, пожалуйста, кто знает!
20 Июля 2014, 13:36:16
Ответ #1
  • Модератор
  • Ветеран
  • *****
  • Сообщений: 86198
  • Репутация: +25412/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В последней версии prestashop 1.5 исправляли эту ошибку.
Вот ссылка, тут написано как самому исправить - Prestashop - Generate watermarks
Если есть ошибки и время выполнение скрипта ограниченно (max_execution_time), то это может так-же вызывать подобную проблему. При возникновении ошибки пишится исключение и скрипт прерывает работу.
21 Июля 2014, 11:27:46
Ответ #2
  • Ветеран
  • *****
  • Сообщений: 33010
  • Репутация: +26761/-0
    • Просмотр профиля
Если есть ошибки и время выполнение скрипта ограниченно (max_execution_time), то это может так-же вызывать подобную проблему. При возникновении ошибки пишится исключение и скрипт прерывает работу.
Исправь ошибки и должно заработать.
21 Апреля 2015, 12:14:25
Ответ #3
  • Новичок
  • *
  • Сообщений: 1
  • Репутация: +0/-0
  • Сообщество PrestaShop
    • Просмотр профиля
Подскажите пожалуйста: после установки стандартного модуля водяной знак, настройке, загрузке файла с текстом и тд после кн сохранить. Вместо сайта белый лист и ошибка 404 ( не найдет URL). Удаление, очистки кэша и прочие подобные процедуры не помогли. Пришлось у хостера фул бэкап просить сделать.
Но все же хотелось бы работать с этим модулем.
Есть может у кого какие советы или опыт с этой проблемой?
21 Апреля 2015, 12:21:28
Ответ #4
  • Ветеран
  • *****
  • Сообщений: 13469
  • Репутация: +14561/-0
  • Сообщество PrestaShop
    • Просмотр профиля
В тех поддержку напиши, может ваш хостинг не поддерживает работу c графической библиотекой PHP GD library.